DO/NEXT vs. EVAL/NEXT vs. EVAL:STEP

DO/NEXT was how you'd do a single step in historical Redbol

This is currently EVAL/NEXT (since DO is higher level and doesn't evaluate lists). But it hadn't occurred to me to question /NEXT...

But I realized that within the code, I call it Eval_Step_XXX(). And the level executor that runs a single evaluation step is called the Stepper_Executor()

So EVAL:STEP (new refinement notation) seems better to me.

>> [pos value]: eval:step [1 + 2 10 + 20]
== [10 + 20]

>> pos
== [10 + 20]

>> value
== 3